ArcGIS Enterprise Questions topics //www.gobook3.com/t5/arcgis-enterprise-questions/bd-p/arcgis-enterprise-questions ArcGIS Enterprise Questions topics Wed, 02 Aug 2023 23:57:08 GMT arcgis-enterprise-questions 2023-08-02T23:57:08Z 附件的元数据,使“returnMetadata”年代ervice? //www.gobook3.com/t5/arcgis-enterprise-questions/attachment-metadata-enable-quot-returnmetadata/m-p/1314641#M36737

I have a service (published from Server) that I'm using in an editing app on AGOL. I'm trying to write a script to pull metadata from the images, but I can't figure out how to access the image metadata. From what I've found, there is a parameter called "returnMetadata", which should be set to True on the service, but I can't see where or how to enable that. (source: https://developers.arcgis.com/rest/services-reference/enterprise/query-attachments-feature-service-layer-.htm )

Wed, 02 Aug 2023 15:59:30 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/attachment-metadata-enable-quot-returnmetadata/m-p/1314641#M36737 MaryGraceMcClellan 2023-08-02T15:59:30Z
ArcGIS Enterprise Profficiency //www.gobook3.com/t5/arcgis-enterprise-questions/arcgis-enterprise-profficiency/m-p/1314437#M36726

Hi Community,

I am fairly proficient in the standard ArcGIS Enterprise workflows - simple deployments, upgrades and very basic troubleshooting for my organization. 

In terms of growing my skills, what would be recommended courses and workflows to undertake? I am aware of the ArcGIS Certifications, however not sure this covers all aspects relating to IT outside of the Esri environment.

Any help/guidance is appreciated.

Wed, 02 Aug 2023 04:52:31 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/arcgis-enterprise-profficiency/m-p/1314437#M36726 FeelingMappy 2023-08-02T04:52:31Z
How is a License Updated in ArcGIS Data Store at 11.x? //www.gobook3.com/t5/arcgis-enterprise-questions/how-is-a-license-updated-in-arcgis-data-store-at/m-p/1314272#M36719

Hi Everyone:

I am attempting to apply new licensing to my Enterprise installation.
When updating the license for ArcGIS Data Store, I usually go to the Data Store tools folder and run the 'updatelicense' batch file.
I panicked!  The utility isn't there!  I search the web and find this:
https://support.esri.com/en-us/knowledge-base/how-to-update-the-arcgis-data-store-license-via-command-000029719

...and at the top of the page...

AdamRepsher_BentEar_0-1690918430526.png

Okay, I am at 11.1 and I need to follow the link...
https://enterprise.arcgis.com/en/portal/latest/administer/windows/data-store-utility-reference.htm#ESRI_SECTION1_0579C1DD4CE44C6F845ED3A192B4205E

It takes me to the top of the Data Store Command Utility Reference because the 'updatelicense' section no longer exists.

Can anyone tell me how the Data Store license is updated in 11.1?

Thank you,
Adam

Tue, 01 Aug 2023 19:44:00 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/how-is-a-license-updated-in-arcgis-data-store-at/m-p/1314272#M36719 AdamRepsher_BentEar 2023-08-01T19:44:00Z
Unable to load ArcGIS elevation service in Cesium //www.gobook3.com/t5/arcgis-enterprise-questions/unable-to-load-arcgis-elevation-service-in-cesium/m-p/1314078#M36715

Are there any specific requirements for the terrain services that can be loaded in Cesium?

I have successfully loaded the official terrain service using the following URL: https://elevation3d.arcgis.com/arcgis/rest/services/WorldElevation3D/Terrain3D/ImageServer

However, when I tried to load my own terrain service hosted on my server(arcgis server 10.6), the Cesium scene appeared as black and failed to load. There were two HTTP requests related to this service, and they seemed to be normal. One of the request URLs looked like this:

{the domain}/arcgis/rest/services/{the service name}/ImageServer?f=json&token=xxxx

and it returned the json data about the service itself.

If compared to the official terrain service, this json data has a few fields that are different:

my service

"serviceDataType": "esriImageServiceDataTypeGeneric",
"capabilities": "Image,Metadata,Mensuration",

official service

"serviceDataType": "esriImageServiceDataTypeElevation",
"serviceSourceType": "esriImageServiceSourceTypeMosaicDataset",
"capabilities": "Image,Tilemap,Mensuration",

The 'SpatialReference' fields are the same. Are there any other information I should pay attention to?

Thanks.

 

Tue, 01 Aug 2023 14:43:56 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/unable-to-load-arcgis-elevation-service-in-cesium/m-p/1314078#M36715 nie 2023-08-01T14:43:56Z
HA Portal Logs //www.gobook3.com/t5/arcgis-enterprise-questions/ha-portal-logs/m-p/1313926#M36705

Hi,

In a scenario where ArcGIS Portal was deployed in HA with an external ELB and assuming that both machines were named:

  • Machine A (Primary)
  • Machine B (Standby)

When I query Portal logs from the REST endpoint, why does it show entries for both Machine A and Machine B executing user actions like when users publish a service despite Machine A acting as the primary. Shouldn't only Machine A do the bulk of the work?

Is this a normal behavior or has it got something to do with the ELB routing to the standby machine instead?

I understand both machines are capable of processing requests and acts as if they're active-active in HA --->Re: Activ-Activ "Portal for ArcGIS" in HA deployme... - Esri Community

 

 

Tue, 01 Aug 2023 04:27:03 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/ha-portal-logs/m-p/1313926#M36705 WengNg4 2023-08-01T04:27:03Z
Hawaii, Alaska and other US territories to be displayed near contiguous US map //www.gobook3.com/t5/arcgis-enterprise-questions/hawaii-alaska-and-other-us-territories-to-be/m-p/1313866#M36704

Hello,

I am researching solutions for having Hawaii, Alaska and other US territories near the contiguous US map. The map is displayed within a web application.

I did find some solutions that allows them to be inserted in different data frames and then controlling the extent. https://developers.arcgis.com/javascript/latest/sample-code/views-composite-views/. However, when I zoom into a county in contiguous US map Hawaii, Alaska which are in separate frames are also there. Is it possible that when a user zooms into a county or any other region within a state the view removes Alaska, Hawaii and only shows zoomed area. This should also happen when we zoom into Hawaii and Alaska too. 

Mon, 31 Jul 2023 21:10:31 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/hawaii-alaska-and-other-us-territories-to-be/m-p/1313866#M36704 learnArcGISMaps 2023-07-31T21:10:31Z
Federated server validation fails after migrating ArcGIS Enterprise 10.9.1 to a new Server //www.gobook3.com/t5/arcgis-enterprise-questions/federated-server-validation-fails-after-migrating/m-p/1313814#M36702 < P >试图升级我们当前ArcGIS对策系统rise 10.9.1 system to 11.1 and also migrate to a new 2022 Windows Server OS. This is a base install where all the enterprise GIS components (Portal, Server, and Datastore) are installed on the single machine. Following the steps outlined in the blog post https://www.esri.com/arcgis-blog/products/arcgis-enterprise/administration/migrate-to-a-new-machine-in-arcgis-enterprise-two/

Steps:

1. Configure a new VM with Windows Server 2022 OS.

2. Installed and configured ArcGIS 10.9.1 on the server. Used Chef automation and configured the system along with federation.

3. Installed all the patches and updated on both the Servers

4. Took a full backup of the existing enterprise GIS using the WebGISDR utility.

5. Imported the backup into the new Server. The import process ran successfully with out any errors. All portal content is available, the hosted feature layers are accessible and can be visualized.

** Only issue is that the ArcGIS relational datastore does not validate and the Federation is broken.
I have attempted this process in three different environments and encountered the same issue.

Attached are the screen shots with the validation errors. 

ArcGIS Server log message:
The connection property set was missing a required property or the property value was unrecognized. This release of the GeoDatabase is either invalid or out of date. DBMS table not found [GDB_Release]

 

Tried to unregister the datastore and reconfigure without any luck. Have an active support case with tech-support. Has anyone encounted a similar problem?

The error message logged doesn't make much sense as the GDB_Relase table does not exist in the database (New or the current functional enterprise GIS)

Any insights, troubleshooting tips or assistance will be greatly appreciated. 

Thanks!

Mon, 31 Jul 2023 19:32:56 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/federated-server-validation-fails-after-migrating/m-p/1313814#M36702 SudhirPonnappan1 2023-07-31T19:32:56Z
Trace Network Problem //www.gobook3.com/t5/arcgis-enterprise-questions/trace-network-problem/m-p/1313541#M36694

Hi there, I need some help.

I want to publish a trace network service, I have tried creating the trace network and it was working properly, but now I am facing some issues, after executing the "Create Trace Network" tool, when I try to set the starting points, that tool appears "blocked"starting_points.png

That did not happen to me before.

In addition, if use as starting points an already existing shapefile, i find the following error:

error.png

And also, i don't know if this last example has anything to do with the previous errors but I cannot edit a new point feature class in the enterprise geodatabase:

error_3.png

Any suggestion??

Thanks in advance

Mon, 31 Jul 2023 10:03:11 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/trace-network-problem/m-p/1313541#M36694 slopezna 2023-07-31T10:03:11Z
Using "clip and ship" on ArcGIS Enterprise //www.gobook3.com/t5/arcgis-enterprise-questions/using-quot-clip-and-ship-quot-on-arcgis-enterprise/m-p/1313535#M36693

Hi.

We have an upcoming project where we need to provide users with downloads of user-defined subsets of raster datasets.

An approach we're considering using is 'clip and ship' functionality.

I just want to check - we will be using ArcGIS Pro to build and publish our datasets to Enterprise.

Is 'clip and ship' still supported in ArcGIS Pro? The documentation I have found for it describes its use in ArcGIS Desktop.

Thanks,

Chris

 

 

Mon, 31 Jul 2023 09:55:28 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/using-quot-clip-and-ship-quot-on-arcgis-enterprise/m-p/1313535#M36693 ChrisThompson8 2023-07-31T09:55:28Z
Max number rows for service in spatiotemporal datastore? //www.gobook3.com/t5/arcgis-enterprise-questions/max-number-rows-for-service-in-spatiotemporal/m-p/1313472#M36686

Hi,

Does anyone have a guide/recommendation on how your spatiotemporal datastore needs to be configured to handle services with >800,000,000 rows? I havent been able to find anything online so far. Or is there a recommended maximum number of rows that I've breached? 

I am using GeoEvent server to add the data to the spatiotemporal datastore.

Current config;

  • 3 node cluster
  • 16 cores + 64 GB RAM for one node
  • 8 core + 64 GB RAM for other two nodes
  • 5 shards
  • replication factor = 1
  • refresh interval = 60 seconds
  • rolling data = monthly
  • shrink = yes
  • aggregation = hex's to level 12
Mon, 31 Jul 2023 01:04:22 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/max-number-rows-for-service-in-spatiotemporal/m-p/1313472#M36686 JessicaRouns 2023-07-31T01:04:22Z
Questions regarding restore of ArcGIS Enterprise on same machine //www.gobook3.com/t5/arcgis-enterprise-questions/questions-regarding-restore-of-arcgis-enterprise/m-p/1313162#M36672 < P >你好社区,,< / P > < P >我们正在运行一个Production machine and have the following set-up:

SET-UP

Machine A: On this machine, we have Server, Portal, DataStore, and PostgreSQL database. 

Machine B: On machine B we have two WebAdaptors installed and configured for ArcGIS Server and Portal. 

We are also using DNS alias so that external users access the portal using DNS alias URL.

SITUATION 

Our IT department wants to upgrade the operating system (OS) of both the machines due to which we'll have to install and configure ArcGIS Enterprise all over again on the same machines with same architecture that we have now. From going the through the following docs: 

I understand we can backup and restore ArcGIS Enterprise through WebGIS DR however following questions comes to my mind

QUESTION

  1. While installing ArcGIS Enterprise more specifically while configuring WebAdaptor should I configure it over DNS alias or FQDN of WebAdaptor Machine. 
  2. Any other things that I should keep in mind while installing and configuring ArcGIS Enterprise after OS upgrade so that the restore works without any errors. 

Any insights would be appreciated. 

 

Fri, 28 Jul 2023 16:44:55 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/questions-regarding-restore-of-arcgis-enterprise/m-p/1313162#M36672 wizgis 2023-07-28T16:44:55Z
How to update IP adress for ArcGIS Server 10.9.1 //www.gobook3.com/t5/arcgis-enterprise-questions/how-to-update-ip-adress-for-arcgis-server-10-9-1/m-p/1313096#M36665 < P >你好,< / P > < P >我已经安装了门户for ArcGIS 10.9.1 (wadesappgis001a) and ArcGIS Server 10.9.1 (wadesappgis002a) on two separated machines. The base installation was successful, but when I would done the federation, it will not work. Research with the IT people, it seems that the used WebAdaptors IP address point to a non desired IP.

Below the situation: on machine wadesappgis002a I have following situation, machine point to two different IP address.

MarcSIMON_0-1690555651183.png

When I install the WebAdaptor, I receive following situation:

MarcSIMON_1-1690555651198.png

How is it possible to force the WebAdaptor from ArcGIS Server to use IP address from machine to IP=10.36.85.14.

I had the same problem with the Portal WebAdaptor, to change the IP Adress, I used the the edit mode.

MarcSIMON_2-1690555651205.png

Is there somewhere a same edit mode for ArcGIS Server or another solution to resolve this?

Best Regards,

Marc Simon

Esri BeLux GIS Defense Consultant

Fri, 28 Jul 2023 14:48:22 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/how-to-update-ip-adress-for-arcgis-server-10-9-1/m-p/1313096#M36665 MarcSIMON 2023-07-28T14:48:22Z
Hosting services are not backed up when using the ArcGIS Server Backup.py tool? //www.gobook3.com/t5/arcgis-enterprise-questions/hosting-services-are-not-backed-up-when-using-the/m-p/1312927#M36661

Hi I am Jin-tae Kim, South Korea GIS User

 

When I restore a Federated ArcGIS Server using restore.py

I coudn't see Hosted Data.

 

Hosting services are not backed up when using the ArcGIS Server Backup.py tool?

 

Does anyone know?

Fri, 28 Jul 2023 03:27:54 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/hosting-services-are-not-backed-up-when-using-the/m-p/1312927#M36661 Jin-taeKim 2023-07-28T03:27:54Z
ArcGIS Enterprise Patch Notification: Connect to proxy server failed after upgrading to 11.1 //www.gobook3.com/t5/arcgis-enterprise-questions/arcgis-enterprise-patch-notification-connect-to/m-p/1312716#M36657

Dear community,

After upgrading to ArcGIS Server 11.1, the Patch Notification tool stopped connecting through the proxy server. Now, it is shown the message "Connection to server failed. Check the proxy host name, port and user credentials for errors."

It was working normally before upgrading, and the same behavior is present in several different servers that went through this process.

Felipe_Costa_0-1690481261158.png

 

Proxy server and credentials are working normally when accessing via browser.

Any ideas?
Thank you!
KR

Felipe

Thu, 27 Jul 2023 18:09:04 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/arcgis-enterprise-patch-notification-connect-to/m-p/1312716#M36657 Felipe_Costa 2023-07-27T18:09:04Z
How to unblock collaboration workspace? //www.gobook3.com/t5/arcgis-enterprise-questions/how-to-unblock-collaboration-workspace/m-p/1312541#M36654 < P >我有一个portal-agol合作手册sync works, but schedule sync remains in a blocked state with no apparant way to unblock it. Pausing and resuming does not work, changing the schedule does not work, in fact, changing every single setting only results in BLOCKED. Blowing away the workspace or the partnership is not an option. 

ThomasColson_0-1690466782987.png

 

Thu, 27 Jul 2023 14:06:35 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/how-to-unblock-collaboration-workspace/m-p/1312541#M36654 ThomasColson 2023-07-27T14:06:35Z
ArcGIS 3D Display Issues with ThinkVision T27p-30 Monitor //www.gobook3.com/t5/arcgis-enterprise-questions/arcgis-3d-display-issues-with-thinkvision-t27p-30/m-p/1312506#M36650

Hi Everyone

Whenever I try to visualize 3D data in ArcGIS on my ThinkVision T27p-30 monitor, I encounter display issues that hinder my ability to work effectively. The problems manifest in the following ways:

Flickering and Ghosting: While navigating through 3D scenes or zooming in/out, the display tends to flicker and exhibit ghosting effects. This makes it challenging to interpret the data accurately and impacts the overall user experience.

Artifacts and Distortions: In some instances, when rendering complex 3D layers or visualizing large datasets, artifacts and distortions appear on the screen. These anomalies create confusion and make it difficult to analyze the data precisely.

Performance Hiccups: It seems that the monitor struggles to handle the 3D rendering demands, causing ArcGIS to lag or freeze sporadically. This results in productivity setbacks and frustration while working on projects.

I am reaching out to the community for any insights or possible solutions to address these ArcGIS 3D display issues with the ThinkVision T27p-30 monitor. If anyone has encountered a similar problem or has expertise in troubleshooting display-related matters, your assistance would be greatly appreciated.

Thank you all for your time and support!

Mon, 31 Jul 2023 11:02:07 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/arcgis-3d-display-issues-with-thinkvision-t27p-30/m-p/1312506#M36650 johnharries 2023-07-31T11:02:07Z
Hosted Map Image Layer in Spatiotemporal Datastore Timing Out in Portal //www.gobook3.com/t5/arcgis-enterprise-questions/hosted-map-image-layer-in-spatiotemporal-datastore/m-p/1312415#M36646

I have a hosted map image layer in a spatiotemporal datastore with approx 700 mil rows. This service drew fine when there were less rows, but now it's getting chunky it is timing out when drawing in Portal, and is taking > 10 minutes to draw in Pro. The associated feature layer is drawing fine (sub 30 seconds) in both Pro and Portal. 

This data was added to the datastore via GeoEvent server. 

Does anyone have recommendations on spatiotemporal datastore configurations to better support very large map image layers?

Current config;

  • 3 node cluster
  • 16 cores + 64 GB RAM for one node
  • 8 core + 64 GB RAM for other two nodes
  • 5 shards
  • replication factor = 1
  • refresh interval = 60 seconds
  • rolling data = monthly
  • shrink = yes
  • aggregation = hex's to level 12
Thu, 27 Jul 2023 04:40:06 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/hosted-map-image-layer-in-spatiotemporal-datastore/m-p/1312415#M36646 JessicaRouns 2023-07-27T04:40:06Z
Unable to register the Portal with the Web Adaptor. Please make sure that the Portal is running and that the account specified has administrative priv //www.gobook3.com/t5/arcgis-enterprise-questions/unable-to-register-the-portal-with-the-web-adaptor/m-p/1311962#M36639 < P >我已经安装了ArcGIS与th Enterprise 11.1e ArcGIS Enterprise Builder on a Windows Server 2019. 

Accepted most default options but I set it to install it to my Data drive, E:\Program Files\

I have run into problems after the install with the ArcGIS Enterprise Configuration Wizard

It gets so far then I get this error: 

Unable to register the Portal with the Web Adaptor. Please make sure that the Portal is running and that the account specified has administrative privileges.

I found this url which details the error:
https://support.esri.com/en-us/knowledge-base/error-unable-to-register-the-arcgis-server-with-the-web-000017734

I can open the ArcGIS Server Manager site and the Portal Site and login no problem with the user just created.

Is there anything else which could be tried to solve this issue?

Wed, 26 Jul 2023 12:13:16 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/unable-to-register-the-portal-with-the-web-adaptor/m-p/1311962#M36639 MartinMcCarry 2023-07-26T12:13:16Z
Map Service Layers count Limitations/Best Practices //www.gobook3.com/t5/arcgis-enterprise-questions/map-service-layers-count-limitations-best/m-p/1311908#M36637

Hi, 

I'm  wondering if there is any limitations or best practices for the limited number (count) of layers can be added to one mapservice with or without FeatureAcces

Wed, 26 Jul 2023 08:16:03 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/map-service-layers-count-limitations-best/m-p/1311908#M36637 RedaAli 2023-07-26T08:16:03Z
ArcGIS Enterprise 11.1 post-upgrade error - webhook requirements //www.gobook3.com/t5/arcgis-enterprise-questions/arcgis-enterprise-11-1-post-upgrade-error-webhook/m-p/1311862#M36635

We have recently upgraded our 10.9.1 ArcGIS Enterprise to 11.1 using ArcGIS Enterprise Cloud Builder for Microsoft Azure. 

The process completed with one recurring error in the portal logs we have yet to address regarding webhook requirements on our ArcGIS Notebook server (see below)

Does anyone have any ideas on how to we can address this particular error?

Portal for ArcGIS error message:

WARNING - An error occurred trying to refresh the webhook configuration on server '<server URL>'. Please check server meets all webhook requirements [Portal Log code 218077]

Additional detail:
The error is repeating every 15 minutes in the portal logs but is only specific to the federated Notebook server (all other federated servers generate a 'success' log). This is consistent across two separate multi-tier ArcGIS Enterprise deployments we have recently upgraded to 11.1.

The error doesn't seem to be impacting users as we can still create ArcGIS Notebooks, configure a Webhook which runs a Notebook and the webhook responds when the configured criteria is met. 

System details:

Windows Server 2019ArcGIS Base Deployment
Windows Server 2019ArcGIS Notebook Server


Additional ArcGIS Notebook Server Details:
Docker Desktop: v4.15.0
Docker Engine: v20.10.21
Docker Images: ArcGIS Standard + Advanced (10.9.1 + 11.1)

Related
Documentation read for troubleshooting:
Webhooks in ArcGIS Enterprise—Portal for ArcGIS | Documentation for ArcGIS Enterprise
Create webhooks—Portal for ArcGIS | Documentation for ArcGIS Enterprise

Wed, 26 Jul 2023 03:37:04 GMT //www.gobook3.com/t5/arcgis-enterprise-questions/arcgis-enterprise-11-1-post-upgrade-error-webhook/m-p/1311862#M36635 MatthewSchulze 2023-07-26T03:37:04Z